This project has moved. For the latest updates, please go here.

Not working

Jul 13, 2010 at 7:10 PM

Ihave install the file to sharepoint 3.0 using stsadm -o addsolution -filename "file"

stsadm -o deploysolution - name "file" -allowacdeployment.

Is this right?

Coordinator
Jul 21, 2010 at 1:44 PM
Edited Jul 21, 2010 at 1:44 PM

The addSolution line looks good, but I typically add the URL parameter when deploying, so it looks like this:

stsadm -o deploysolution -name ReadWriteSecurity.wsp -url https://www.companywebsite.com -local -allowGacDeployment

Also, don't forget to active the feature. You can activate it by going to the Site Collection Features list and enabling 'Read/Write Security'.

Tim

Oct 2, 2010 at 10:38 PM

I was so excited to find this tool.  I didnt check which version it was for and deployed to sharepoint 2010.  The install and deployment went fine and I was able to activate.  When I tried to use the app I got an error:  Could not load file or assembly 'Microsoft.SharePoint.ApplicationPages, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

How can I make this work on 2010?

Coordinator
Oct 5, 2010 at 6:44 PM

Sscarcella,

You are right - this only works on Sharepoint 2007 at this time - not on 2010.  However, I'll see if I can get a 2010 version going.  It might take me a couple of weeks, as I'll need to get a Sharepoint 2010 development environment set up, but I'll see what I can do.

    Tim

May 5, 2011 at 2:16 PM

I have the same issue as sscarcella. Is there a new version that works with 2010?

Thank you.